Emailing Non-Collaborators with Pro Plan

My company has recently upgraded to the Pro plan for multiple reasons, but one of them being we need have to be email to send email automations to non-collaborators that are a part of our team.

We have set up and tried so many ways of emailing these non-collaborators but nothing seems to work. When we first set up the automation, our team member received two email notifications and then it suddenly stopped working and she has not received any since.

Does anyone know if there would be a reason for this? The automation says it is running properly when tests are done. Could it be an issue on the non-collaborators end? In the back end of our admin’s permissions?

Any tips/ideas would be helpful considering Air Table help has not been.

Welcome to the community, @moirapuls!

Can you please post all the screenshots of how you’ve setup your automation?

We had set up two different automations using both email options to try to find out which would work if anything. This photo is just the one, I will attach the second as well. I also went in and connected the gmail account in the automations hoping that would do the trick but still nothing.

Let me know if you need another screenshot that has other information from the automation included. Thank you for helping. :slight_smile:

Here is the second.

That looks like it should work. When you change a record’s submission type to “New Request”, what happens? You can check your “Run History” at the top of that screen to see what happens.

Just did what you asked. Shows that it went through and I received the email as well so I know if worked. I just messaged the gal who’s email is in this automation and she has not gotten back to me yet. What I do find interesting about this automation though is the run history.

A lot of these show they were ran successfully but she never received the emails from any of them. The few month gap between the most recent and the one ran in May is very large as well and there were many new requests coming in during that time. Any thoughts on this?

Maybe a spam filter or other limitations on her side?

Yeah, as @Databaser mentioned above, maybe they ended up in her spam folder? In your latest screenshot, the messages are being sent by Google (not Airtable), so if there’s any problem on the sending side, it would be a Google problem. You can log into, look in your “Sent Mail” folder, and you should see the outgoing messages there.

I had asked her in the past to check her spam folder a few times and she’s always told me there were no emails from air table in there.

Just as a clarification, when hooking up an email account to Air Table automations, that is the email that is “sending” these outgoing automated emails? So if my email were in that spot and she received a “new request” email, the sender would be me?

Also, do you know if there were be some type of setting in my admin’s back end of air table that could possibly prevent this automation from functioning properly?

I really appreciate all the help you guys are giving me. Any advice is much appreciated!

I don’t know what Airtable’s and Google’s rules are for delivering emails, but if you’re sending using the Gmail action, the email is being sent from your connected Google account. Did you log into your connected Google account and check your “Sent Mail” folder to see if the email was sent?

If you can’t get it to work with Airtable’s automations, you can always give it a try with Make’s Gmail Automations.

There is a small learning curve with Make, which is why I created this basic navigation video to help. I also provide the links to a few other Make training resources there as well.

Thank you for trying to help. I’ll take a look at the 2 links you sent and if I need anything else I will reach out. Thanks again.