Is it a bug or was it always like that - buttons only for 3rd party to extensions (non-Airtable apps)

I can’t start Airtable own published extensions using button fields. It only allows me to attach 3rd party extensions. Makes no sense. Why would Airtable restrict that? Was it always the case, or were they fixing something and they forgot to turn it back on?

Which Airtable extensions are you trying to open with a button field? You can open Page Designer with a button field.

Other extensions don’t make much sense to open with a button field because they do not have meaningful info for a single record. For example, the Chart extension doesn’t show a chart for a single record.

If you want to open such an extension from a button field, you really only need to open the dashboard for the extension. One approach I have used is to design a dashboard with a Page Designer extension at the top that is basically a plain text heading. Then I have the button field open that Page Designer. As a result, the entire dashboard opens, including the chart or other extensions for the user to see.

1 Like

Yes, My bad. Thank you for reminder.

I actually have answered the same question a while ago. I can actually copy the link to the actual extension and I have done the same when I was trying to share an extension.

The separate dashboard idea is good, that will help. Although, I still wish all extensions would be available through the button field, it highlights the extension when licked on it instead of having to search for the right version of the extension I need and I have plenty.

For instance, I have quite a few extensions and for the CSV Import Extension I have a few copies each instance configured to import a different CSV because using one instance to import different CSV templates doesn’t work reliably and the import is faster than using or If during the import I pick the wrong instance of CSV Import extension for the wrong CSV file, the auto-match will often miss a field. Having dedicated CSV import extension for one CSV template works more reliably.

I love this clever trick, @Kuovonne!! Great idea!!

Speaking of extensions, I just discovered yesterday that Airtable has downgraded the functionality of their embed extension. In the past, this extension used to allow us to put the URL of an Airtable form into the extension, but it no longer allows us to do that anymore. Now, it gives us an error message when we try to insert the URL of an Airtable form.

Works for me. I just tried. I just copy the highlighted part of the link.



Oh wow, @itoldusoandso! Thank you so much! You just solved this problem for me & my client!! :star_struck: :raised_hands: :clinking_glasses: :dizzy:

The embed extension used to accept just the normal form URL, but now it requires that extra “embed” part of the URL!

In other words, it used to accept a form link like this:

But now it requires a form link like this:

Thank you! :smiley:

I emailed Airtable support about this issue, and they just updated their support article today on this issue:

Embedding Airtable share links

The embed extension stopped accepting the Airtable share link format late 2022. In order to allow an embed extension to function properly, you’ll need to adjust share links to include:

The result should look something like this:

Note that this differs from the iframe embed code created when you choose to create an embeddable share link.