Airtable OAuth/Personal Token migrations in Make make me loose a weekend

It sucks is when I need to update the Airtable modules in Make is the need to redo the modules from scratch when forced to do the upgrade. I have some complicated workflow with close to 100 steps and Airtable has just over 20 modules. The older v1 modules in Make need to be replaced because they don’t seem to support the new Airtable OAuth/PersonalTokens.
There is no easy way to apply upgrade to the modules. At least they could have provided a way to update the existing modules on a click of a button with a warning attached. Instead of that need to remove module, add module, reconnect all and check things etc. My Airtable tables span over 100’s of fields and in some cases I am updating dozens of fields in one step and I concatenate fields when updating Airtable.

When reconnecting Airtable I got warning about reaching the maximum possible OAuth authorizations to external apps. Is there a maximum limit for maximum external connections from Integromat to Airtable OAuth?
I switched all my Airtable modules to now to Personal Tokens and didn’t see the warning again.
Yet again had to go through all scenarios.
Maybe it’s me I created a mess and didn’t make a backup before I started fussing with this.

The Integromat to Make migration works fine otherwise.
I am updating this whole weekend.
Wish there was a way to automate this. How many times do I have to go through this in the future? Ah well.

1 Like

Are you adding a new connection for each module? You should just be selecting from the dropdown the new connection.

Edit, just tested myself and it allows you to just change the connection in existing modules. no need to even make a new module. Just change the connection in the current ones.


As @joshsorenson said and as he properly corrected you, you are doing it completely wrong. While it is still a little bit time consuming, you simply need to update each existing Airtable module.

Furthermore, you only need to establish ONE Airtable connection in Make (per set of workspaces in Airtable), not multiple connections.

Also, to speed up the migration of each scenario, you can use the Chrome DevTool:

I forgot about the extension. It’s done now.

No - no I am not creating new connection. I am reusing the same connection from the drop down menu. I had 2 connections to Airtable - the old API key and then added 1 OAuth connection. I am using one of the Airtable tables I use for a small project with with 6 other people to sync with their google Photos accounts via Integromat. Maybe that is the reason it didn’t like it. Probably should have done through shared Airtable tables but I found it was more work that way.

For the Version 1 Airtable module - there is no option to add OAuth / Personal Token. I can’t add it. It DID show an error where I would normally go to add it. Yet, I had already the login saved for Oauth connection in settings. The old Airtable API did work fine. The version 1 Airtable modules needed to be deleted and new version module needed to be added.

The v2 and v3 have a choice of API/ OAuth / Personal Token and that was right away visible in that menu.
I used Integromat since the first day they started so I had quote old Airtable modules, never updated so maybe it was an old Airtable module.

Interestingly - after I migrated, went back there to look again to take screenshot and the window shows completely differently. Now it tells me the API keys are deprecated. That message wasn’t even there before I was upgrading from Integromat to Make.

Anyways is already done now so I can’t even take screenshots.

This is how it looks now. Before the migration, I didint’ see that whole red box, and where it says “My Airtable Token or Key Connection” it was showing another red box in grey letters telling me something there is an error.

Another problem for me with Make migration was for connections that were not presently connected to a workflow. These were not migrated. On some workflows I have a couple of accounts that I switch manually when I decide to because I run the workflows only once in a while.

Only the connection attached to workflow got migrated. Any other connections I had there “parked” did not transfer. Grr… So had to spend time recreating those connections in Make.

Okay so in fact I did make a screenshot of that. I thought I don’t have anything but I do… Here is what I got when I was doing migration of the v1 Airtable modules in Make. This I don’t remember if this was also happening in Integromat because I didn’t try and now I can’t anymore because the workflows seem are read-only. But in Make, this is the error I was getting and there is no place to add OAuth or Personal Token as it is in the v2 and v3 modules.

I thought to submit this to Make support, but then I thought, what’s the point, it’e over now.